ICEfaces
  1. ICEfaces
  2. ICE-11280

ace:accordion: Add support for icecore:repeat children

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.2
    • Fix Version/s: EE-4.2.0.GA
    • Component/s: ACE-Components
    • Labels:
      None
    • Environment:
      jsf2 ace accordion icecore

      Description

      The current ace:accordion component does not allow for any other children other than ace:accordionPane. In order to use the icecore:repeat component (new), the renderer code would need to be modified to allow this type of markup:-
      {code}
      <ace:accordion id="accordion">
          <icecore:repeat id="repeat" value="#{mainMenuBean.subMenuList}" var="SubMenu" >
                <ace:accordionPane >
                         #{SubMenu.name}
               </ace:accordionPane>
             </icecore:repeat>
       </ace:accordion>
      {code}

        Activity

        Mircea Toma added a comment -

        Factored out accordion pane renderer to allow the accordion component to render any type of child. Also modified the AccordionRenderer to render its children at the right location in the markup.

        Liana Munroe added a comment -

        Tested with ICEfaces 4 trunk r51436, Tomcat 8, IE 11, FF 47, Chrome 57.
        I was not able to make the content render unless the icecore:repeat was inside the ace:accordionPane. If written as per the description in this JIRA with the ace:accordionPane inside the icecore:repeat , no content is rendered.

        New test app /ICE-11280 was added to http://dev.icesoft.com/svn/repo/qa/trunk/Regression-Icefaces4/Sparkle/Manual/repeat.

        Mircea Toma added a comment -

        I modified ICE-11280.xhtml test page to run icecore:repeat component over the accordion panes, not the content of them.

        Liana Munroe added a comment -

        I had the third pane written as such so that when the fix was in it would be rendered.

        Mircea Toma added a comment -

        Reverted the test page since it was indeed already testing the fix (I missed the iteration for "Panel 3"). The test is running well, the first two panes are rendered and then third panel is repeatedly rendered for as many items are in test.list collection.

        Liana Munroe added a comment -

        Verified ICEfaces 4 trunk r51442, Tomcat 8, MS Edge, IE 11, 9, FF 47, Chrome 57


          People

          • Assignee:
            Mircea Toma
            Reporter:
            Judy Guglielmin
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: