ICEfaces
  1. ICEfaces
  2. ICE-11258

Replace h: components in Showcase with ace: versions

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: EE-4.2.0.GA
    • Component/s: Sample Apps
    • Labels:
      None
    • Environment:
      ICEfaces 4.x Showcase sample application
    • Assignee Priority:
      P1
    • Affects:
      Sample App./Tutorial

      Description

      There are many instances in the ICEfaces 4 Showcase sample application where standard JSF "h:" components are used in the demos where alternative/superior "ace:" and "mobi:" components could be used.

      The most obvious benefit of doing this is the superior ThemeRoller-based styling that the ICEfaces components will use.

      There may be specific demos where the use of the h: components is required in order to show specific functionality or compatibility, these instances should be preserved.
      1. commandButton.png
        151 kB
      2. selectBooleanCheckbox.png
        171 kB
      3. selectMany.png
        39 kB
      4. selectOneMenu.png
        66 kB

        Issue Links

          Activity

          Ken Fyten added a comment -

          Attached screenshots of the search results for the main h: components to be replaced.

          Liana Munroe added a comment -

          ICEfaces 4 trunk r51622
          The following issues are caused by commits to date for ICE-11258.

          1.) ace:audioPlayer > Overview
          Controls such as loop, autoplay and muted are no longer functioning.

          2.) Can not access autoCompleteEntry > Match Criteria demo: HTTP Status 500 - /resources/examples/ace/autocompleteentry/autoCompleteEntryMatch.xhtml @41,80 <ace:ajax> Error: ace:ajax specifies an event name that is unsupported by its parent ClientBehaviorHolder. Event name: valueChange, Parent: org.icefaces.ace.component.checkboxbutton.CheckboxButton@124c1301, Valid values: [action]

          3.) Can not access Bean define swatch tab in colorEntry > Swatches demo: java.el.PropertyNotFoundException
          08-Jun-2017 10:53:54.594 SEVERE [http-apr-8080-exec-6] com.sun.faces.context.Aja
          xExceptionHandlerImpl.handlePartialResponseError javax.el.PropertyNotFoundExcept
          ion: /resources/examples/ace/colorEntry/colorEntrySwatches.xhtml @78,91 colorFor
          mat="#

          {colorEntrySwatchesBean.rgbPcolorFormat}

          ": Property 'rgbPcolorFormat' not
          found on type org.icefaces.samples.showcase.example.ace.colorEntry.ColorEntrySwa
          tchesBean
          at com.sun.faces.facelets.el.TagValueExpression.getValue(TagValueExpress
          ion.java:111)
          at org.icefaces.ace.component.colorentry.ColorEntryBase.getColorFormat(C
          olorEntryBase.java:474)
          at org.icefaces.ace.component.colorentry.ColorEntryRenderer.encodeEnd(Co
          lorEntryRenderer.java:130).....

          4.) confirmationDialog > Overview - Styling issue
          Now that ace comps are used the dialog container itself is too small. Also it should not require a scroll bar.

          5.) dataTable > Paginator - inputTexts not replaced by ace:textEntry

          6.) draggable > Draggable demo - The div that was put into the demo so that the draggable could not be dragged off the page was replaced by a h:panelGroup . Please revert this change or add the div back and change the id on the panelGroup accordingly. The draggable should be confined to within the demo space contraints.

          Liana Munroe added a comment - - edited

          Tested with ICEfaces 4 trunk r51659.
          Issues 1, 2, 3, and 6 as listed above are resolved.
          Remaining issues:
          confirmationDialog > Overview, Effect - Styling issue
          Now that ace comps are used the dialog container itself is too small. Also it should not require a scroll bar.
          dataTable > Paginator - radiobuttons, checkboxbutton not replaced by ace components

          Remaining issues have been added to ICE-11334

          Judy Guglielmin added a comment -

          reopen for confirmationDialog -> Overview and ->Effect

          Judy Guglielmin added a comment -

          resolved rev 51707

          Liana Munroe added a comment -

          Verified confirmationDialog style issue resolved ICEfaces 4 trunk r51707, Tomcat 8, MS Edge, IE 11, 10, 9, 8, FF 47, Chrome 59.


            People

            • Assignee:
              Judy Guglielmin
              Reporter:
              Ken Fyten
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: