ICEfaces
  1. ICEfaces
  2. ICE-11202

Errors when using Safari Private browsing mode

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: EE-3.3.0.GA_P01, 4.1
    • Fix Version/s: 4.2.BETA, 4.2, EE-3.3.0.GA_P05
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      IceMobile 1.3.1.GA_P01_Fedex06, ICEfaces 4 trunk

      Description

      FedEx is seeing some script errors when they run their application using IceMobile 1.3.1.GA_P01_Fedex06 in Safari Private browsing mode.

      Case description: "Is Private mode not supported by IceMobile on Safari? I'm seeing multiple JS errors when a user is in private mode and IcePush doesn't work either. I attached images of those errors (QuotaExceededError and undefined is not an object errors)."

        Activity

        Arran Mccullough added a comment -

        Attached screen shots of the errors seen.

        Ken Fyten added a comment -

        Note that these failures are also seen when using desktop Safari in Private Browsing mode, with ICEfaces 4.x showcase.

        Firefox, in private window mode, does not have these failures.

        Need to investigate the root cause and see if there is anything to be done about it.

        Mircea Toma added a comment -

        Fix local storage detection to work even if the window.localStorage global variable is present but non-functional.

        Liana Munroe added a comment -

        Tested with ICEfaces 4 trunk r49980 and icemobile trunk r49986 using Safari browser in private mode.

        IF4 trunk showcase - Native components demos are not loaded on the page (private browsing mode only)
        When opening the IF 4 trunk showcase / mobile Cloud Push demo in private window, it fails with a JS error. See screenshot console1.png

        icemobile trunk r49986 mobileshowcase - When opening the icemobile 1.3 trunk mobileshowcase in a Private Safari window, the attached QuotaExceeded JS errors are logged. Most demos seem to continue to function, however, attempting to navigate to the Cloud Push demo adds the bottom JS error when it tries to init push. See attached screenshot console2.PNG

        Mircea Toma added a comment -

        All the errors are generated by the access to window.localStorage from bridgeit.js code. Safari pretends that the local storage is available but full when running in private mode.

        Ken Fyten added a comment -

        Since the remaining issues are specific to BridgeIt, marking this as Fixed.

        There is no requirement for bridgeit.js to function in private mode at this time.


          People

          • Assignee:
            Mircea Toma
            Reporter:
            Arran Mccullough
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: