ICEfaces
  1. ICEfaces
  2. ICE-11471

blockUIOnSubmit, overlay is not removed when downloading resource

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: EE-3.3.0.GA_P07
    • Fix Version/s: EE-3.3.0.GA_P08
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      Any

      Description

      When using the org.icefaces.blockUIOnSubmit context parameter and downloading a resource via ace:dynamicResource the overlay is not removed after completing the download, and the UI remains blocked.

        Activity

        Arturo Zambrano added a comment - - edited

        The issue is that when org.icefaces.blockUIOnSubmit is active, the blockUI will be applied on page unload, which is triggered when downloading a resource in the same window. So, this issue is not limited to ace:dynamicResource. It occurs with any element or component that tries to load a different URI on the current window.

        The workaround is to load the resource in a new window.

        Arturo Zambrano added a comment -

        r53064: Added fix to prevent the blocking UI from being applied for ace:dynamicResource

        Arturo Zambrano added a comment -

        Applied fix to customer's branch at revision 54065.


          People

          • Assignee:
            Arturo Zambrano
            Reporter:
            Arturo Zambrano
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: