ICEfaces
  1. ICEfaces
  2. ICE-11455

Version 73.0.3683.103 (Official Build) (64-bit) Chrome problems with dispose of views

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: EE-1.8.2.GA_P10, EE-3.3.0.GA_P06, EE-4.3.0.GA
    • Component/s: Bridge
    • Labels:
      None
    • Environment:
      Chrome 73.0.3683.103
    • Support Case References:
      Support Case 14470 (IF 3.3.EE):-https://icesoft.my.salesforce.com/5000g000024tvYq?srPos=0&srKp=500
      Support Case 14471 (IF 4.3.0-EE):-https://icesoft.my.salesforce.com/5000g000025meu6
      Support Case 14472 (IF 1.8.2-ee):-https://icesoft.my.salesforce.com/5000g000025meu6
      Show
      Support Case 14470 (IF 3.3.EE):-https://icesoft.my.salesforce.com/5000g000024tvYq?srPos=0&srKp=500 Support Case 14471 (IF 4.3.0-EE):-https://icesoft.my.salesforce.com/5000g000025meu6 Support Case 14472 (IF 1.8.2-ee):-https://icesoft.my.salesforce.com/5000g000025meu6

      Description

      reports of problems with dispose-views with latest update of Chrome

      possible issue reported:-
      https://chromium.googlesource.com/chromium/src/+/ae67f3d81e68cbe54942fb187a97e39225b36b00
      could be related.

      Was reported that could be reproduced using WindowsScope tutorial example. I tested on my Mac with latest Chrome and could not reproduce with either 3.3.0_P06 or 4.3.0_EE versions....so wondering if this is a windows/Chrome issue?
      Will also attach other relevant info from support cases to this Jira.

        Activity

        Mircea Toma added a comment - - edited

        Use Navigator.sendBeacon native function when available to avoid using a synchronous XHR.
        Chrome will not issue a XHR request anymore when is issued right before the page unloads. Also see https://developer.mozilla.org/en-US/docs/Web/API/Beacon_API/Using_the_Beacon_API.

        Mircea Toma added a comment -

        Applied patch to dev.icesoft.com/svn/ossrepo/icefaces-ee/patches/icefaces-ee-1.8.2.GA_P10-11455.


          People

          • Assignee:
            Mircea Toma
            Reporter:
            Judy Guglielmin
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: