ICEfaces
  1. ICEfaces
  2. ICE-11447

possible regression tabSetProxy with nested ace:tabSet

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.3
    • Fix Version/s: EE-4.3.0.GA_P01
    • Component/s: ACE-Components
    • Labels:
      None
    • Environment:
      ace

      Description

      see attached test page and screenshots
      1. tabLab.xhtml
        1 kB
        Judy Guglielmin
      1. tabLab 4.2.PNG
        12 kB
      2. tabLab 4.3.PNG
        8 kB

        Activity

        Arturo Zambrano added a comment -

        r52898: modified getContainerClientId() to work the same way as in h:form

        The issue was caused by ICE-11281. The getContainerClientId() method should've been returning null if the id wasn't prepended. The method from h:form in mojarra was copied to these components (ace:tabSet, ace:accordion, and ace:panelStack).

        Arturo Zambrano added a comment -

        Made tabs display as inline-block to fix visual issues with nested tab sets.
        r52987: 4.x trunk
        r52988: 4.3 P01 tag


          People

          • Assignee:
            Arturo Zambrano
            Reporter:
            Judy Guglielmin
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: