ICEfaces
  1. ICEfaces
  2. ICE-11289

allow filterBy attribute to contain multiple values within <ace:column/>

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.2
    • Fix Version/s: EE-4.2.0.GA, EE-3.3.0.GA_P05
    • Component/s: ACE-Components
    • Labels:
      None
    • Environment:
      jsf2 ace

      Description

      Currently the filterBy attribute allows a single string to be used from a selection of values.

      The use of filtering by multiple values allowing the following valid markup:-
      {code}
      <ace:column>
           filterBy="#{user.firstName} #{user.lastName}"
          filterOptions="#{user.nameOptions}"
      .......
      </ace:column>
      {code}

        Activity

        Liana Munroe added a comment - - edited

        Tested with ICEfaces 4 trunk r51581 using myfaces 2.2.12 libs. The filter selection issue as seen in my last comment is present even when loading the main showcase page first and navigating to the demo by clicking the menu on the left.
        When using mojarra libs and navigating through the menu the issue is not seen.

        Arturo Zambrano added a comment -

        r51607: added code to preserve the open/closed state of the filter facet across requests, in order to avoid the facet suddenly close when the whole table markup is updated

        This takes care of the issue with myfaces as well as the issue with mojarra.

        Liana Munroe added a comment -

        Verified ICEfaces 4 trunk r51622, myfaces and mojarra libs, Tomcat 8, MS Edge, IE 11, 10, 9, 8, FF 47, Chrome 57.

        Arturo Zambrano added a comment -

        r51632: backported last fix to the 3.3 EE maintenance branch

        Liana Munroe added a comment -

        Verified ICEfaces EE-3.3.0 maintenance branch r51633, myfaces and mojarra libs, Tomcat 8, MS Edge, IE 11, 10, 9, 8, 7 FF 47, Chrome 57.


          People

          • Assignee:
            Arturo Zambrano
            Reporter:
            Judy Guglielmin
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: