ICEfaces
  1. ICEfaces
  2. ICE-11224

Hover CSS not removed on ACE menu components in IE

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: EE-4.1.0.GA, EE-3.3.0.GA_P04
    • Fix Version/s: 4.2, EE-3.3.0.GA_P05
    • Component/s: ACE-Components
    • Labels:
      None
    • Environment:
      IE, ACE menu components

      Description

      In IE browser only, if you right click on an ace:menu, menuBar, or menuButton menu item, the hover CSS is applied but not removed on mouse out. The hover CSS stays till a reload happens or another rich click occurs.

      This is reproducible with the Showcase demos.

        Activity

        Arran Mccullough added a comment -

        Attached test case that reproduces the issue in a different way.

        Steps:

        • Load welcomeICEfaces.jsf in IE11
        • Click on the "Open Window" menu item. A new window is opened.
        • Going back to the parent window, the menu item is still highlighted.
        Arturo Zambrano added a comment -

        r50536: fix for removing ui-state-focus styling when focusing out

        This is actually a programmed behaviour to add the ui-state-focus style class to menu items. It just so happens to be triggered on right clicks as well, and the styling looks the same as the hover styling. This fix adds an event listener to remove such styling when focusing out.

        Arturo Zambrano added a comment -

        r50537: Committed fix to the 3.3 EE maintenance branch.

        Arran Mccullough added a comment -

        I did a quick test with this fix and it does look like it resolves the right-click behavior but the issue with the sample app is stoll present. The test case is for a left-click which opens a new window.

        Arturo Zambrano added a comment -

        r50545: fix for preventing focus styling on menu items that contain a call to open a new window (window.open())

        Highlighting the last focused item was actually the way things are supposed to work. If you try the ace:menuBar Overview demo and click on the 'Home' menu item, it will open a new window, and it will be highlighted in order to be able to tab through the rest of the menu items. Clicking anywhere else on the page removes this styling.

        I tried to prevent this behaviour anyway in many obvious ways and non-obvious ways, but it was impossible to do it, because the sudden change to a new window makes it hard to keep track of the original event, and because the event used (focusin) is a synthetic event, there's not enough information about how the even really started. So, I went for a brute force approach to prevent this focus styling on items that open new windows via the window.open() function. That's the only solution unless we want to spend more time making major modifications to the Wijmo code. I hope it solves the customer request.

        Arran Mccullough added a comment -

        Can this fix be added to the 3.3.0 maintenance branch as well?

        Arturo Zambrano added a comment -

        r50553: applied latest fix to the 3.3 maintenance branch


          People

          • Assignee:
            Arturo Zambrano
            Reporter:
            Arran Mccullough
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: