ICEfaces
  1. ICEfaces
  2. ICE-11135

ace:dataTable - LazyDataModel load() method called multiple times

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: EE-3.3.0.GA_P03, 4.1.1, EE-4.1.0.GA, EE-3.3.0.GA_P04
    • Fix Version/s: EE-4.2.0.GA, EE-3.3.0.GA_P05
    • Component/s: ACE-Components
    • Labels:
      None
    • Environment:
      All

      Description

      An ace:dataTable set to use lazy loading is calling the load() method of the associated LazyDataModel multiple times on each llifecycle. When first loaded on the page it is called 3 times. Each interaction, page change for example, it is called 3 times as well.

      This seems to be an issue since the EE 3.3.0 P03 release, the P02 release it is only called once.

        Activity

        Arran Mccullough added a comment -

        Attached test case that shows this issue.

        Steps:

        • Load welcomeICEfaces.jsf
        • The following is shown in the server logs:
          LazyDataModel load() Called!
          LazyDataModel load() Called!
          LazyDataModel load() Called!
        Ken Fyten added a comment -

        Art, is this a duplicate of the one you recently resolved for EE 4.2?

        Arturo Zambrano added a comment -

        Closing this issue as a duplicate of ICE-10880. This issue is already fixed and committed to the 4.2 trunk and the EE 3.3 maintenance branch. The load() method has to be called twice per lifecycle, as explained in the first comment of ICE-10880.


          People

          • Assignee:
            Arturo Zambrano
            Reporter:
            Arran Mccullough
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: