ICEfaces
  1. ICEfaces
  2. ICE-11049

ace:fileEntry - Add browser level title tooltip for input field in IE

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: EE-3.3.0.GA_P03, 4.1.1
    • Fix Version/s: EE-4.2.0.GA, EE-3.3.0.GA_P05
    • Component/s: ACE-Components
    • Labels:
      None
    • Environment:
      IE

      Description

      Currently when hovering over the input field after a file has been uploaded, there is a browser level title tooltip shown in Firefox. This tooltip is not shown in IE.

      This is likely due to how the browsers render an HTML <input type="file"...> component.

      This JIRA is to investigate possibilities in having IE render a similar browser level tooltip.

      The main reason for this is to display the content of the input field in the tooltip, which is helpful if the file name length is longer than the width of the input field.

      This behavior can be reproduced with the Showcase demo's.
      1. Chrome.png
        21 kB
      2. FF.png
        20 kB
      3. IE11.png
        18 kB
      4. MSedge.png
        17 kB

        Activity

        Arturo Zambrano added a comment -

        r51743: improvement to display a native browser tooltip when hovering over the file input field, across browsers

        Added an onchange listener to the file input to add a title attribute to the parent div, displaying the name of the file. Note that this is only applicable in the single mode, since in the multiple mode all file input elements are hidden plus the file names are displayed in the table below. This is also not applicable if autoUpload="true", because it's just not necessary.

        Liana Munroe added a comment -

        Verified ICEfaces EE-4.2.0.RC1 Jenkins build 2, MS Edge, IE 11, 10, 9, 8, FF 47, Chrome 53. Each browser has a different tooltip text as seen in attached screen-shots.
        Reopening because the fix needs to be backported to EE-3.3.0 branch.

        Arturo Zambrano added a comment -

        r51754: backported fix to the EE 3.3 maintenance branch

        Liana Munroe added a comment -

        Verified ICEfaces EE-3.3.0 maintenance branch r51820, Tomcat 8, MS Edge, IE 11, 10, 9, 8, 7, FF 55, Chrome 60.


          People

          • Assignee:
            Arturo Zambrano
            Reporter:
            Arran Mccullough
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: