ICEfaces
  1. ICEfaces
  2. ICE-11316

ice:selectInputText - Options drop down list issue in IE11 / Edge

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: EE-3.3.0.GA_P04, EE-1.8.2.GA_P09
    • Component/s: ICE-Components
    • Labels:
      None
    • Environment:
      IE11, Edge

      Description

      An ice:selectInputText component is used inside of an ice:panelPopup component. When typing in characters into the input field, the option drop down list is only seen for a few milliseconds and is gone. This is making selection of an option impossible in IE11/Edge browsers.

      The main cause of this issue looks to be setting of the autoPosition attribute of the ice:panelPopup. If this is not set, the issue is not reproducible.

        Activity

        Arran Mccullough created issue -
        Arran Mccullough added a comment -

        Attached test case to reproduce the issue.

        Steps:

        • Load welcomeICEfaces.jsf in IE11/Edge browsers
        • A panelPopup will already be shown. In the input field, type a character, any character.
        • The option list will be shown very quickly.
        Arran Mccullough made changes -
        Field Original Value New Value
        Attachment Case14116Example3.war [ 22545 ]
        Attachment Case14116Example3.zip [ 22546 ]
        Ken Fyten made changes -
        Assignee Arturo Zambrano [ artzambrano ]
        Fix Version/s EE-3.3.0.GA_P05 [ 13082 ]
        Fix Version/s EE-1.8.2.GA_P10 [ 13089 ]
        Assignee Priority P2 [ 10011 ]
        Ken Fyten made changes -
        Assignee Priority P2 [ 10011 ] P1 [ 10010 ]
        Arturo Zambrano added a comment -

        r51817: added explicit detection for ie11 and Edge for the autoposition code to run correctly on those browsers

        Arturo Zambrano made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Liana Munroe added a comment -

        Not able to reproduce issue using attached test case.

        Arturo Zambrano added a comment -

        r51832: backported fix to the 1.8 trunk

        Repository Revision Date User Message
        ICEsoft Public SVN Repository #51832 Tue Aug 15 15:13:56 MDT 2017 art.zambrano ICE-11316 (backport) added explicit detection for ie11 and Edge for the autoposition code to run correctly on those browsers
        Files Changed
        Commit graph MODIFY /icefaces/trunk/icefaces/bridge/lib/extras/style.js
        Ken Fyten made changes -
        Summary ice:selectInputText - Options drop down list issue in IE ice:selectInputText - Options drop down list issue in IE11 / Edge

          People

          • Assignee:
            Arturo Zambrano
            Reporter:
            Arran Mccullough
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: