ICEfaces
  1. ICEfaces
  2. ICE-10459

ace:gMap add support for displaying multiple services on the same map

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: EE-4.2.0.GA
    • Component/s: ACE-Components
    • Labels:
      None
    • Environment:
      Any

      Description

      As found in ICE-10347, displaying multiple services on the same map is supported by the Google Maps API, but it's not supported in ace:gMap with ace:gMapService. Fixing the way services are added to a map in our ace:gMap javascript code should solve this issue.

        Activity

        Arturo Zambrano created issue -
        Ken Fyten made changes -
        Field Original Value New Value
        Fix Version/s 4.1 [ 11375 ]
        Ken Fyten made changes -
        Issue Type Bug [ 1 ] Improvement [ 4 ]
        Arturo Zambrano made changes -
        Assignee Arturo Zambrano [ artzambrano ]
        Ken Fyten made changes -
        Assignee Arturo Zambrano [ artzambrano ]
        Fix Version/s 4.2 [ 12870 ]
        Fix Version/s 4.1 [ 11375 ]
        Ken Fyten made changes -
        Fix Version/s EE-4.2.0.GA [ 13071 ]
        Fix Version/s 4.2 [ 12870 ]
        Ken Fyten made changes -
        Assignee Arturo Zambrano [ artzambrano ]
        Arturo Zambrano added a comment - - edited

        r51533: fix to support multiple direction services on the same map

        The other services didn't require this fix, since they aren't displayed on the map, they just provide information.

        Arturo Zambrano made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Repository Revision Date User Message
        ICEsoft Public SVN Repository #51533 Tue May 16 10:58:00 MDT 2017 art.zambrano ICE-10459 fix to support multiple direction services on the same map
        Files Changed
        Commit graph MODIFY /icefaces4/trunk/icefaces/ace/component/src/org/icefaces/ace/component/gmap/GMapServicesMeta.java
        Commit graph MODIFY /icefaces4/trunk/icefaces/ace/component/resources/icefaces.ace/gmap/gmap.js
        Liana Munroe added a comment -

        Verified ICEfaces 4 trunk r51549, tomcat 8, MS Edge, IE 11, 10, 9, FF 47, Chrome 57.
        Added test app /gMapMultipleServices.jsf to http://dev.icesoft.com/svn/repo/qa/trunk/Regression-Icefaces4/Sparkle/Manual/gMap


          People

          • Assignee:
            Arturo Zambrano
            Reporter:
            Arturo Zambrano
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: